Windows Vista SP2 Beta – Initial impressions

So I just installed SP2 of Windows Vista which is out in beta on my computer yesterday – so it’s been about 24 hours and my computer is stable and all of the applications I’ve used so far have worked just fine. The only bizarre issue that I’ve noticed so far is the uninstall of .NET framework 3.5 SP1. I can’t really explain it and I’m not even sure if this was the SP2 beta install but Paint.NET stopped working with an error message that it needed .NET Framework 3.5 SP1. Paint.NET was working before the SP2 beta install and so I just reinstalled .NET Framework 3.5 SP1 and everything worked. Not sure what happened there and as I said, could be completely unrelated but that’s the only strange thing that’s happened so far.

There is a list of new features and fixes at Microsoft and Mary-Jo’s blog. So far, the beta feels fairly solid and I hope this is a watershed release like Windows XP SP2 was for XP but I guess time will tell or Windows7 will be out and we won’t care about Vista. (Or we’ll be running Ubuntu or OS X and we won’t care about Windows 🙂 – Hope spring eternal!)

Here are some screen shots of Windows update on my machine doing the update for SP2.

If you want to try the beta yourself, Microsoft has a page on how to enable the download via Windows Update.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s